PHP远程代码执行漏洞 (CVE-2022-31626)
日期:2022-09-14 10:47:01  发布人:信息化建设中心  浏览量:0

组件介绍

PHP,即“超文本预处理器”,是一种开源的通用计算机脚本语言,尤其适用于网络开发并可嵌入HTML中使用。

PHP的语法借鉴吸收了C语言、JAVA和Perl等流行计算机语言的特点,易于一般程序员学习,其主要目标是允许网络开发人员快速编写动态页面,也被用于其他领域。

漏洞简介

2022年6月10日,深信服安全团队监测到PHP远程代码执行漏洞信息。漏洞编号:CVE-2022-31626,漏洞威胁等级:高危。

该漏洞源于在PHP的mysqlnd扩展(MySQL数据库扩展)中存在缓冲区溢出的安全问题,攻击者可利用该漏洞在未授权情况下,伪造MySQL服务器与目标站点连接,最终可获取服务器最高权限。

影响范围

PHP是一种开源的通用计算机脚本语言,尤其适用于网络开发并可嵌入HTML中使用。使用PHP开发的站点广泛遍布于全球,因此此可能受漏洞影响的资产广泛分布于世界各地,涉及用户量较大,导致漏洞影响力很大。

受漏洞影响的PHP版本如下:

8.1.0 ≤ PHP < 8.1.7

8.0.0 ≤ PHP < 8.0.20

7.0.0 ≤ PHP < 7.4.30

官方修复建议

当前官方已发布最新版本,建议受影响的用户及时更新升级到最新版本。


 

联系电话:023-42464987 重庆人文科技学院信息化建设中心 版权所有